Cart issue during checkout
Incident Report for Hydrow
Resolved
This issue has been fully resolved and we're closing the incident.
Posted Nov 07, 2023 - 14:34 EST
Monitoring
All systems are back to normal.

We identified the issue. Our merchant partner had a technical issue, which they report is resolved.

We are continuing to monitor.
Posted Nov 07, 2023 - 11:46 EST
Investigating
We have identified that many people can't checkout purchases on the hydrow.com website. We are investigating.

The Hydrow product is not affected.
Posted Nov 07, 2023 - 11:10 EST
This incident affected: hydrow.com website and shop.hydrow.com.