hydrow.com website not accessbile

Incident Report for Hydrow

Resolved

The issue has been resolved, and hydrow.com is loading normally.

If you have a problem reaching hydrow.com, please reload your browser window. If the problem persists, contact http://support.hydrow.com.

The cause of the problem was with one of our infrastructure partners. Once their error was resolved, our issue was also resolved.
Posted Aug 07, 2024 - 16:01 EDT

Investigating

Several people are unable to get to hydrow.com, and are seeing an error message when they try to.

There are no reports of problems with the Hydrow application - workouts, stats, and mobile apps etc.

We are investigating.
Posted Aug 07, 2024 - 15:29 EDT
This incident affected: hydrow.com website.