Hydrow.com Website Issue
Incident Report for Hydrow
Resolved
The problem has been resolved. Hydrow.com is operating normally.

We continue to monitor for any additional issues.
Posted Jun 29, 2023 - 12:01 EDT
Identified
We are continuing to investigate the problem with hydrow.com, and have identified the immediate cause of the problem.

The hydrow.com website pages are working properly, except the shopping cart and purchase process are still not loading.

The Hydrow service is not impacted by this issue; workouts, meter tracking, etc. are not affected.

We will provide our next update within 30 minutes.
Posted Jun 29, 2023 - 11:44 EDT
Investigating
The hydrow.com website is freezing and unresponsive for some US users.
Posted Jun 29, 2023 - 10:57 EDT
This incident affected: hydrow.com website.