hydrow.com website outage
Incident Report for Hydrow
Resolved
This incident has been resolved.
Posted Feb 12, 2022 - 17:17 EST
Monitoring
We have identified the cause and hydrow.com is loading. We are continuing our investigation and testing of the full website.
Posted Feb 12, 2022 - 17:05 EST
Update
Direct access to https://shop.hydrow.com/ is working.
Posted Feb 12, 2022 - 17:00 EST
Investigating
We are investigating an outage on hydrow.com which prevents shopping, browsing, and purchases. The Hydrow application (workouts, etc.) and support.hydrow.com appear to be unaffected.
Posted Feb 12, 2022 - 16:52 EST
This incident affected: hydrow.com website and shop.hydrow.com.