Headline: Unable to add products to cart on

Incident Report for Hydrow

Resolved

Website and cart operation have returned to normal and appear stable. Marking as resolved.

If you have a problem adding to cart on hydrow.com, please reload your browser window. If the problem persists, contact http://support.hydrow.com.

The root cause of the problem was with one of our infrastructure partners. Once their error was resolved, our issue was also resolved.
Posted Aug 23, 2024 - 11:56 EDT

Monitoring

Errors from this incident appear to have stopped. Monitoring a few minutes to be sure things are resolved.
Posted Aug 23, 2024 - 11:52 EDT

Investigating

We are aware that some customers are unable to add products to their cart on hydrow.com.

There are no reports of problems with the Hydrow application, workouts, workout stats, or mobile apps.

We are investigating.
Posted Aug 23, 2024 - 11:39 EDT
This incident affected: shop.hydrow.com.