Customers are unable to reach our Hydrow store.

Incident Report for Hydrow

Resolved

This incident has been resolved.
Posted Oct 02, 2022 - 08:07 EDT

Monitoring

The problem has been identified and corrected.
Posted Oct 02, 2022 - 08:02 EDT

Investigating

Customers are unable to reach our Hydrow store. We are investigating.
Posted Oct 02, 2022 - 07:56 EDT
This incident affected: shop.hydrow.com.