Degraded Hydrow.com Checkout

Incident Report for Hydrow

Resolved

The checkout incident has been resolved by our service provider.
Posted Jun 16, 2023 - 05:15 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 16, 2023 - 05:14 EDT

Identified

Our checkout service is experiencing an issue which may result in a degraded checkout experience. Some Hydrow.com visitors may experience issues or delays with checkout, or when moving from cart to checkout. We have observed this specifically with mobile devices. Our service provider has identified the problem and is investigating.
Posted Jun 16, 2023 - 04:59 EDT
This incident affected: hydrow.com website.