Difficulty creating new memberships
Incident Report for Hydrow
Resolved
We continue to see normal membership creations and no unexpected card declines through our payment processor since ~3pm Eastern Time. We will be marking this incident as resolved.
Posted Dec 20, 2023 - 16:37 EST
Monitoring
We have begun to see successful memberships being created in our system again. Including some using cards that were previously being declined. We are continuing to monitor and work with our payment processor to make sure that Hydrow memberships can be created smoothly.
Posted Dec 20, 2023 - 16:07 EST
Identified
This issue appears to be related to specific types of charges being declined through our 3rd party payment processor. We are currently working with them to determine root cause and resolve.
Posted Dec 20, 2023 - 15:30 EST
Investigating
We are aware of an issue that is currently preventing new memberships from being created on Hydrow. Existing memberships and workouts appear unaffected. We are investigating and will provide updates as we learn more.
Posted Dec 20, 2023 - 15:02 EST
This incident affected: Hydrow Service.