Time-outs on Shop.hydrow.com
Incident Report for Hydrow
Resolved
All website activity has remained stable. Updating to resolved.
Posted Mar 13, 2023 - 15:51 UTC
Monitoring
Shopping cart performance and Checkout appear to be back to normal. Monitoring status.
Posted Mar 13, 2023 - 15:45 UTC
Investigating
Customers have reported experiencing long loading times on our shopping website and we are investigating. Workouts and the hydrow app are NOT impacted.
Posted Mar 13, 2023 - 15:38 UTC
This incident affected: shop.hydrow.com.