UK Membership Issues

Incident Report for Hydrow

Resolved

This incident has been resolved.
Posted Mar 08, 2022 - 12:55 EST

Update

We are continuing to investigate this issue.
Posted Mar 08, 2022 - 12:55 EST

Update

This issue has been resolved. UK Subscriptions are working as normal. Closing the issue.
Posted Mar 08, 2022 - 12:53 EST

Update

We are continuing to investigate this issue.
Posted Mar 08, 2022 - 12:44 EST

Investigating

We have heard several reports from Hydrow Members in the UK of difficulties signing up for Hydrow membership or renewing membership. We are investigating and will update ASAP
Posted Mar 08, 2022 - 12:44 EST
This incident affected: Hydrow Service.