support.hydrow.com unreachable
Incident Report for Hydrow
Resolved
support.hydrow.com is fully accessible.
Posted Jul 31, 2021 - 02:09 UTC
Monitoring
support.hydrow.com is accessible again. The problem appears to have been with our support partner's infrastructure. We are monitoring for any recurrence.
Posted Jul 31, 2021 - 01:55 UTC
Investigating
We are currently investigating this issue.
Posted Jul 31, 2021 - 01:37 UTC
This incident affected: hydrow.com website.