Hydrow Service Impacted

Incident Report for Hydrow

Resolved

We have seen no new incidents of this error in the last 20 minutes. We are considering this issue resolved and closing the incident.
Posted Jul 21, 2023 - 12:27 EDT

Monitoring

We believe this issue should now be fixed and the symptoms resolved. We are continuing to monitor.

We will update again within 30 minutes.
Posted Jul 21, 2023 - 12:07 EDT

Identified

We have now identified the root cause for these error messages and are actively working to resolve.

We expect to share another update within the next half hour.
Posted Jul 21, 2023 - 11:48 EDT

Investigating

We are currently investigating a number of reports of degraded service for some Hydrow Members. Symptoms may include difficulty signing in to a profile or signing up for membership.

We will update here when more information is available.
Posted Jul 21, 2023 - 11:33 EDT
This incident affected: Hydrow Service.