Hydrow.com Website Issue
Incident Report for Hydrow
Resolved
The problem has been resolved. Hydrow.com is operating normally. We continue to monitor for any additional issues.
Posted Jul 28, 2023 - 18:24 EDT
Investigating
We are investigating reports that some users are receiving a 503 error when attempting to navigate to hydrow.com. The Hydrow service is not impacted by this issue; workouts, meter tracking, etc. are not affected.
Posted Jul 28, 2023 - 17:44 EDT
This incident affected: hydrow.com website.