Hydrow Service Unavailable
Incident Report for Hydrow
Resolved
Normal Service has been restored and has appeared to be stable for the last half hour. We are marking this incident as resolved.
Posted May 26, 2022 - 11:59 EDT
Monitoring
Service appears to be back to normal levels for the last 15 minutes or so. We will continue to monitor, but will call this resolved soon if there are no further issues.
Posted May 26, 2022 - 11:47 EDT
Identified
We have clarified the nature of the issue and are working to mitigate. We're starting to see some successful log-ins. We will continue to monitor.
Posted May 26, 2022 - 11:26 EDT
Update
Log-in on Hydrow and related apps remains unavailable. A 3rd party hosting service may be involved in the outage. We are continuing to investigate but do not yet have an ETA for restoration of service.
Posted May 26, 2022 - 10:55 EDT
Investigating
Service for Hydrow devices and apps is currently unavailable for some users. We are investigating.
Posted May 26, 2022 - 10:17 EDT
This incident affected: Hydrow Service.