issue with checkout - purchasing is blocked
Incident Report for Hydrow
Resolved
The issue has been resolved.
Posted Nov 13, 2023 - 16:39 EST
Monitoring
Our merchant partner has resolved the underlying issue, and we have corrected the problem it caused in our systems. Customers should be able to purchase normally.

Any customers who are having difficulties with their shopping cart should use another browser, or contact Hydrow Support.

We apologize for any inconvenience this caused.
Posted Nov 13, 2023 - 16:26 EST
Investigating
We have identified that many people can't checkout purchases on the hydrow.com website. We are investigating.

The Hydrow product is not affected.
Posted Nov 13, 2023 - 16:00 EST
This incident affected: hydrow.com website and shop.hydrow.com.